Solution: Zabbix Database error after upgrading to 4.0

IT & Software | Other
5.0 (1 ratings)
Description
  1056:20180924:131446.582 cannot use database "zabbix_server_db": database is not a Zabbix database
  1065:20180924:131456.827 Starting Zabbix Server. Zabbix 4.0.0 (revision 86552).
  1065:20180924:131456.827 ****** Enabled features ******
  1065:20180924:131456.827 SNMP monitoring:           YES
  1065:20180924:131456.827 IPMI monitoring:           YES
  1065:20180924:131456.827 Web monitoring:            YES
  1065:20180924:131456.827 VMware monitoring:         YES
  1065:20180924:131456.827 SMTP authentication:       YES
  1065:20180924:131456.827 Jabber notifications:      YES
  1065:20180924:131456.827 Ez Texting notifications:  YES
  1065:20180924:131456.827 ODBC:                      YES
  1065:20180924:131456.827 SSH2 support:              YES
  1065:20180924:131456.827 IPv6 support:              YES
  1065:20180924:131456.827 TLS support:               YES
  1065:20180924:131456.827 ******************************
  1065:20180924:131456.827 using configuration file: /etc/zabbix/zabbix_server.conf
  1065:20180924:131456.832 [Z3005] query failed: [0] PGRES_FATAL_ERROR:ERROR:  relation "users" does not exist
LINE 1: select userid from users limit 1 
Attachments
No attachments
Solutions
Description
Did the process of updating databases fail, is it necessary to check why? Probably not installed zabbix-web-4.0.1-1.el7.noarch.rpm and zabbix-server-pgsql-4.0.1-1.el7.x86_64.rpm package.
on November 14th, 2018 (6:57 pm)
All coments
Thanks, package zabbix-server-pgsql-4.0.1-1.el7.x86_64.rpm not installed.

on November 14th, 2018 (7:00 pm)
ok
on November 18th, 2018 (9:44 pm)
You must sign in to comment!! LOGIN
We use cookies to give you the best possible experience on our site. By continuing to use the site you agree to our use of cookies. Find out more Accept